Something is amiss
Incident Report for Simplero
Resolved
And we're back in business!
We'll post more details here about what happened after we do a full post-mortem.
Posted Oct 22, 2020 - 20:59 EDT
Investigating
As you've noticed, something is amiss in Simplero-land. We're on it and will get it fixed ASAP.
Posted Oct 22, 2020 - 20:47 EDT
This incident affected: Web interface and API.