Email Delivery Delay
Incident Report for Simplero
Resolved
This incident has been resolved.
Posted Nov 04, 2023 - 04:43 EDT
Identified
We are currently experiencing issues with our email provider, which has resulted in delays in email delivery. Outgoing emails may be affected. Our technical team is actively working on resolving this issue and is in communication with the email provider.
Posted Nov 04, 2023 - 02:31 EDT