Auto-response and Automation email delivery stats are not complete
Incident Report for Simplero
Resolved
This issue is now resolved and emails sent during this issue should now show correct statistics.
Posted Jun 28, 2021 - 15:51 EDT
Monitoring
We have implemented a fix and new stats should now be recorded correctly. We are monitoring this fix and exploring methods to update the data on affected email during the issue.
Posted Jun 28, 2021 - 15:09 EDT
Investigating
All emails are still being sent, don't worry! But we are currently investigating an issue where the email stats for these messages are zero or incomplete.

The number of 'Delivered' emails is not correct, and thus the percentages of other things (like 'Opens') are also wonky. As far as we can tell, other number-based metrics like 'Opens' are accurate - only percentages are affected. The problem may lie with SendGrid, but we haven't fully identified the issue yet. We're on it, though!

Our apologies for any inconvenience.
Posted Jun 28, 2021 - 12:56 EDT