Partial Outage: DNS Degradation Affecting Domains hosted on Simplero

Incident Report for Simplero

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 18:57 EST

Identified

We’re currently experiencing a partial outage affecting some domains due to a service degradation at our DNS provider. As a result, some visitors may see intermittent issues such as:

- Website not loading / “site can’t be reached”

- SSL warnings (in some cases)

- Missing pages or broken links

- Intermittent access to Simplero-hosted pages on impacted domains/subdomains

We’re actively investigating and monitoring the status while working to reduce impact.
Posted Feb 10, 2026 - 13:37 EST