NMI outage

Incident Report for Simplero

Resolved

NMI has resolved the issue and are now monitoring.
Posted Sep 26, 2025 - 19:16 EDT

Investigating

A payment gateway called NMI is currently experiencing issues.
Only transactions going through this particular processor are not working.
They are aware of this, and we'll announce here once they resolve it
Posted Sep 26, 2025 - 17:57 EDT
This incident affected: Spreedly Gateway Integrations.