Simplero is down
Incident Report for Simplero
Resolved
We've resolved the issue and everything should be back to normal.
Posted Nov 14, 2024 - 05:13 EST
Identified
Our engineers are working on a spam traffic attack that's bringing us down.
Posted Nov 14, 2024 - 02:53 EST
This incident affected: Web interface and API.