Site is down ... working on it

Incident Report for Simplero

Resolved

All good now. Thanks for your patience.
Posted Sep 17, 2020 - 12:04 EDT

Identified

Most stuff is back online now.

Looks like it's just our own website (simplero.com) that's still borked. Your sites and services are working fine, and you can login to your account by going to youraccount.simplero.com/admin.
Posted Sep 17, 2020 - 11:28 EDT

Investigating

We made a boo-boo. We're working hard on restoring service.

So sorry, guys. We know we screwed up.
Posted Sep 17, 2020 - 11:23 EDT