Processing delays

Incident Report for Simplero

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 09:32 EST

Monitoring

A fix has been implemented and emails, automations and triggers should all be executing normally.
There is an edge case that was causing issues and bringing the whole system down.

We will continue monitoring the processes in case another edge case happens
Posted Dec 29, 2025 - 06:23 EST

Identified

We have identified the issue and are working on a fix.
Posted Dec 29, 2025 - 05:17 EST

Investigating

We are currently investigating an issue causing delays on triggers, automations and email delivery.
Posted Dec 29, 2025 - 04:53 EST
This incident affected: Background processing.