Email Delivery Delays
Incident Report for Simplero
Resolved
This incident has been resolved.
Posted Oct 18, 2024 - 08:28 EDT
Identified
We are currently experiencing an issue impacting our email delivery system. Users may notice delays in receiving emails sent through our platform.

Current Status: Our engineering team has identified the root cause as an unexpected surge in email load, leading to a bottleneck in our processing queues. We are actively working fixing it.
Posted Oct 18, 2024 - 05:58 EDT