Microsoft has decided to mark some of our domains as "suspicious"

Incident Report for Simplero

Resolved

We seem to be off the naughty list! Our testing shows that the warning doesn't appear anymore when using Microsoft Defender SmartScreen.

Big thanks to all of you who reported the domains as safe.
Posted Jun 25, 2025 - 09:43 EDT

Identified

There's no good reason for this, as far as we're aware. It's happened once before, many moons ago, and it was a fluke. It's something they do from time to time, and there's little we can do. We've reached out to them and we hope they'll get it fixed soon.

In the meantime, please:

* mark the site as 'safe'
* tell your clients to do the same
* tell your clients to ignore the warning or use another browser

Telling Microsoft the site is safe will hopefully help change their minds.

We're super sorry about this, but sometimes these giant corporations do what they do and we can't stop them.
Posted Jun 19, 2025 - 09:30 EDT