Emails may not be sending
Incident Report for Simplero
Resolved
This issue appears to have been resolved. A small number of emails may not have been sent between 2:28 PM and 3:34 PM EST on October 12. If you sent messages around that time, please check to see if the broadcasts are marked as 'not delivered'.
Posted Oct 13, 2021 - 10:25 EDT
Monitoring
This issue appears to have been resolved, but we are monitoring to make sure no further issues occur.
Posted Oct 12, 2021 - 17:24 EDT
Investigating
We are experiencing an issue were some emails may not be delivering.
Posted Oct 12, 2021 - 15:09 EDT