Custom domains not being served ...
Incident Report for Simplero
Resolved
Actually, I was wrong, it was just my own custom domain (calvincorreli.com) that wasn't working, because I'd messed with it. I think. Let me know if you come across anything that's not working. I'll keep checking and monitoring...
Posted 8 months ago. Feb 06, 2018 - 12:48 EST
Identified
Getting it fixed right away ... on it!
Posted 8 months ago. Feb 06, 2018 - 12:40 EST