Unusually high traffic is causing slowdowns
Incident Report for Simplero
Resolved
Argh, the interaction of three things!

We've recently added compression of CSS and JS for your sites and membership sites, and it turns out we'll have to reengineer that a bit. It's way too slow to do on-the-fly. That's a do-over. We've paused the compression for now.
Posted 23 days ago. Jun 01, 2018 - 09:25 EDT
Investigating
Fixed the other issue, now we're seeing very high load, which is causing requests to wait and some to time out. We're on this.
Posted 23 days ago. Jun 01, 2018 - 08:59 EDT
This incident affected: Web interface and API.