Known issue with Safari 9.1
Incident Report for Simplero
Resolved
We've turned off HTTP/2 for now. Seems that's what was causing the problem.
Posted over 1 year ago. May 18, 2016 - 08:39 EDT
Monitoring
There seems to be an issue with posting content from Safari from a page that's been open for a while.

We upgraded our webserver (nginx) over the weekend, and this seems to be a bug between that version of nginx and Safari 9.1.

We'll look into this in more detail tomorrow.

In the meantime, either post again, or use another browser for now.

I (Calvin) personally use Safari 9.1 as my primary browser, so I'm affected by this, too.

Details here: https://forum.nginx.org/read.php?2,266525,266525#msg-266525
Posted over 1 year ago. May 17, 2016 - 23:09 EDT