We're a little unstable at the moment
Incident Report for Simplero
Resolved
We should be all back to normal now.
Posted over 1 year ago. May 23, 2016 - 20:01 EDT
Identified
Nick and I are making changes to the server, and it's causing a little bit of wonkiness and slow requests. In the end, everything should be better.
Posted over 1 year ago. May 23, 2016 - 18:27 EDT