We're experimenting with a new CDN
Incident Report for Simplero
Resolved
Switching back for now. We need to resolve a few issues with HLS video playing.
Posted over 1 year ago. Apr 05, 2016 - 10:46 EDT
Monitoring
The CDN - Content Delivery Network - is the component that makes it fast to access videos and other media files, no matter where in the world you're located.

We've switched to a new one. It might cause some problems. It should make things work better. But it's hard to know until you try.

Let us know through the HELP link in your account if you experience any issues.
Posted over 1 year ago. Apr 05, 2016 - 08:38 EDT