Dashboard access for some accounts not working
Incident Report for Simplero
Resolved
I was able to speed up the "Purchases waiting for manual payment" table dramatically, and it's now been restored for all accounts.

I'm sorry for the interruption.
Posted about 1 month ago. Oct 06, 2018 - 12:21 EDT
Identified
It was the Pending purchases table on the dashboard that broke it for those accounts. I've removed that for now, while I figure out how to make it perform again.
Posted about 1 month ago. Oct 06, 2018 - 11:46 EDT
Investigating
I'm working hard to figure out what's going on for those accounts and restore access as soon as possible.
Posted about 1 month ago. Oct 06, 2018 - 11:43 EDT