We're down, should be back up in minutes
Incident Report for Simplero
Resolved
Actually, we were only down for Nick and myself. Haha. All good :)
Posted 6 months ago. May 05, 2017 - 14:17 EDT
Investigating
So sorry.
Posted 6 months ago. May 05, 2017 - 14:12 EDT