QuickPay subscription payments failing
Incident Report for Simplero
Resolved
Issues with QuickPay subscriptions should now be resolved.
Posted about 1 year ago. Oct 01, 2016 - 18:37 EDT
Identified
QuickPay is moving all customers from their old system to their new system right now. An issue with translation of subscriptions means that we are currently unable to process any subscription payments. We are awaiting a solution to the problem from QuickPay.
Posted about 1 year ago. Sep 30, 2016 - 18:14 EDT