Looks like Amazon is having some network problems right now, affecting Simplero's operations
Incident Report for Simplero
Resolved
They seem to have gotten it under control now.
Posted 10 months ago. Sep 14, 2017 - 16:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Sep 14, 2017 - 15:01 EDT