We're not overwhelmed... we're adding features
Incident Report for Simplero
Resolved
We're back in business. Thank you for your patience.
Posted over 1 year ago. Apr 08, 2016 - 10:26 EDT
Monitoring
Right now, you're getting a message saying Simplero is overwhelmed. That's not the case. We're deploying the multi-currency upgrade, and I've taken Simplero offline while the database migration is in progress. Should only be a matter of minutes.
Posted over 1 year ago. Apr 08, 2016 - 10:17 EDT