We're down, we know, we're working hard on getting back online
Incident Report for Simplero
Resolved
We hit a snafu with the database, but we're back up. Thank you for your patience!
Posted 6 months ago. Jan 04, 2018 - 14:45 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Jan 04, 2018 - 14:22 EST