Issues with videos not playing
Incident Report for Simplero
Resolved
Figured it all out.
Posted almost 2 years ago. Mar 01, 2016 - 22:00 EST
Update
Flash seems to be broken. Still investigating.
Posted almost 2 years ago. Mar 01, 2016 - 16:15 EST
Investigating
We are investigating why this is happening
Posted almost 2 years ago. Mar 01, 2016 - 16:12 EST