Looks like sometimes pages get served with the wrong certificate
Incident Report for Simplero
Resolved
Working now.
Posted 13 days ago. Feb 06, 2018 - 13:47 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 13 days ago. Feb 06, 2018 - 12:55 EST
Investigating
it's serving the simplero.com certificate instead of the certificate we have for your domain. I'm looking into it. I think it's just that two of the webservers didn't get upgraded properly.
Posted 13 days ago. Feb 06, 2018 - 12:55 EST