Some web servers are being naughty
Incident Report for Simplero
Resolved
All is good in the world again.
Posted 21 days ago. Sep 02, 2018 - 11:28 EDT
Identified
They're not coming up right ... should be back in business shortly.
Posted 21 days ago. Sep 02, 2018 - 11:26 EDT