EU VAT number validation experiencing issues
Incident Report for Simplero
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 21, 2017 - 16:01 EDT
Identified
EU VAT number validation is currently experiencing issues. We are working on a fix
Posted 7 months ago. Mar 21, 2017 - 15:05 EDT