We're deploying an upgrade, and it's causing some delays in background processing
Incident Report for Simplero
Resolved
We're back to normal. Thanks for your patience!
Posted over 1 year ago. May 22, 2016 - 13:45 EDT
Identified
I'm on it. We'll get things moving again shortly.
Posted over 1 year ago. May 22, 2016 - 12:55 EDT