A bit more problems in the background processing... working on it, will get it resolved ASAP
Incident Report for Simplero
Resolved
Everything's back to normal. Thank you for your patience.
Posted over 1 year ago. May 22, 2016 - 17:13 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. May 22, 2016 - 16:13 EDT