We're flapping ... going up and down. I'm on it...
Incident Report for Simplero
Resolved
we seem to be back, baby!
Posted over 2 years ago. May 22, 2016 - 23:56 EDT
Monitoring
We seem stable again.
Posted over 2 years ago. May 22, 2016 - 23:52 EDT
Investigating
We are currently investigating this issue.
Posted over 2 years ago. May 22, 2016 - 23:46 EDT